Thursday, July 17, 2008

Nokia Maps part II

So you've read my adventures with Nokia Map Loader, well it turns out that v2 should be able to load maps from PC Suite when the phone is in PC Suite mode.

Well maybe. If you launch Map Loader and it just sits there saying “waiting for device” then you need to delete a directory on the SD card in the phone.

OK, you say. But check the directory. Its where the maps are. So the advice is delete the maps and download them all over. Grrrrr!

From Nokia forums, posted by Nokia person:

- People having problems with “waiting for device” or “Unable to read all information…”, you could try the following:

1. make sure you have maps 1.2 wk30 or later (or 2.0)
2. connect the device in mass storage mode, it will show up as a drive in windows
3. delete the folder E:\Private\20001f63 (including sub folders)
4. start maps on the device once, it will recreate the folder in a different location
5. connect the device in pc suite mode and start maploader


Yes, great. I'll connect in Mass Storage mode, thank you!

12 comments:

Justin said...

Marvellous - I had just the same problem with my N95 and this worked like a treat. Thanks muchly...

Brent said...

Had same problem with N95. I stopped the map loader, browsed the memory card using Nokia file manager, then restarted the map loader, and it all worked fine! Maybe Nokia software needs to be shown where the Nokia E: drive is.
Cheers

Pettrie de Bondt said...

Thanks for the info, I could not find the 'private' folder when using the Nokia file manager. At last I removed the storage chip and inserted it directly into my PC, romoved the folder. Restarted everything and YES!! It works!

Gary said...

I have tried all the fixes sugested and had no luck.
Maploader either gives the message unable to conect to device or unable to conect to the server.
I am getting very frustrated.
Is there anything else I can try?

Anonymous said...

Thank you very much for this... t'was appreciated!

All the best,
J.

Anonymous said...

Thks for the info.
That folder was on the phone , not my SD card.
Fixed the drive not found problem.

For those that can't connect to the internet you need to check that IE is not using any proxy settings for internet access.
I believe it gets the settings from there but then can't authenticate to a proxy server. You might need direct internet access. eg. From home not work.

Anonymous said...

Thank you. It worked and resolved Map Loader waiting for device ... problem with my N95. In my case, it requires connection using Mass Storage Mode after the folder deletion - PC Suite mode does not work.

GenialMex said...

It just worked wonderful, thanks a lot.

Alex said...

I can access the 'Private' folder using the Mass Storage method, but there is no such folder '2000something' inside.

To get this right:
I installed Maps onto Nokia PC Suite. I haven't managed to download any maps yet because of this "Waiting for device" problem. I haven't transferred any files onto the phone or the memory card either. Is that what I was supposed to do or am I wrong in not doing something in the first place?


Thanks a lot!

QuiteTall said...

This sounds like it might be a different problem. You say you are in mass storage mode, so you are using the USB lead?

Anonymous said...

after reading hundreds of forums, and following every step, still cant get the freakin software to work... I am using N97-mini... and the nokia maps loader pisses me off !!

Anonymous said...

what happens / does not happen?