Thursday, December 31, 2009

Installing OSX on Lenovo S12 Netbook

I decided to get another netbook. My MacBook Pro 13" is great, and my MSI Wind / Advent 4211 is also great. But the Macbook is costly so I don't like taking it out of the house, and the Wind has a screen res thats too low for me ie I need bigger than 1024 x 600.

After a lot of looking , I settled on the Lenovo S12. Its a 12" screen with a resolution of 1280 x 800, same as the Macbook Pro. Doing some Googling suggested it has similar hardware to the S10 which takes OSX well. To confirm I removed the HD from my Wind (easy to do), connected to a USB adapter, and booted the S12.

For some reason on cold boot the BIOS does not pick up the external drive. So press Fn+F11 (which equals F12) on boot and at the boot select screen press Ctrl+Alt+Del to reboot. The USB should now be picked up, so press Fn+F11 and select the external drive.

All seemed OK, so after backing up the WinXp installation (in case I want to sell the S12) using the excellent Macrium disk imaging tool I took the plunge. I should note that right from the off I was not expecting the ethernet or mic to work. Likely ever.

I started with the MSiWindOSX86 base. Burn to DVD, place in DVD and use IDE / USB adapter.

Remove the battery! Don't know why but the installer fails if you don't.

Had to do the double boot noted above.

When the installer has started, and you see the 'welcome' screen go to the utilities menu and select Disk Utility. Click on your hard drive in the left hand window, then select 'erase'. Call your HD something.

Then quite Disk utility and you go back to the installer.

Select customise. I deselected 'additional fonts' and 'extensions > realtek R1000' since the S12 doesn't have Realtek ethernet, it has Broadcom 57x gigabit FastLink.

Let the installer finish, and then restart. Add your account details just like you would with a regular OSX install.

Right, lets start fixing stuff!

1. no Wifi - Broadcom card not picked up correctly: go here http://www.insanelymac.com/forum/index.php?showtopic=51725, look for bcm43xx_enabler_0.5.3.sh.zip. Unzip and run:

sudo: ./bcm43xx_enabler.sh

2. The screen color profile is wrong. Go to http://s10lenovo.com/download/file.php?id=235. Save it to /library/colorsync/profiles/display. To use it, go to System Preferences / Display / Color and select 'huey D65 G2.5 A0.00'. Will make screen look 'brownish' - thats OK!

3. Install 10.5.8. Go to Apple to get the combo update. Run the update. It takes an AGE. For me it was stuck at 3 minutes for more like 30. Eventually it did complete.

At this point likely I made an error. I did a restart and the keyboard and mouse did not work, though as expected I'd lost the 1280 x 800 graphics and QE.

4. So I got out an Apple USB keyboard and USB mouse. I installed CyberGreg's MSi OSX86 Upgrade Pack v1.5 from MSi_OSX86_Upgrade_Pack_v1.5.zip

I deselected 'audio' 'network' and 'trackpad'. Another restart and that fixed the keyboard and mouse, and I now have Quartz Extreme.

5. Then I wanted to have 'about this mac' show correctly. Download 10.5.8_Thireus_Fixes_3.4 and run the package 'about this mac'.

6. OK, sound. Get the s10(e) drivers package and install 'AzaliaAudio', 'CHUD' and extract 'Audieee_1.0.1' to your Applications folder. Another restart, and then launch Audieee. It adds an item to your menu bar which you can use to control sound. By default sound is off, so select speakers or headphones.

At this point, this is whats working:
KB, trackpad
wireless
Quartz Extreme
Bluetooth
UK keyboard layout
Sound out

Whats not working:
ethernet
sleep
sound in / mic

Untested:
ExpressCard slot
External video

update 1: had problems with the fan being on all the time. Installing AppleACPIPlatform.kext seems to have fixed it.

update 2: the ExpressCard slot works - I've got a eSATA adapter in there, backing up to eSATA HD. Not bootable, but thats not such a big problem.

update 3: sound stopped working, and for a while I wondered if sound was broken with a hardware fault. So I installed Ubuntu, and sound worked fine. I've now got sound out working again using VoodooHDA.kext and Audieee. The audieee page says to use the AppleAzaliaAudio.kext, but ignore that! The mic is also working but only the built in - I have a headphone / mic headset, and the audio in does not re-direct to it.

Wednesday, December 30, 2009

Using wget to download bulk or batch or whole directories

I needed to download all the images in a directory. Seemed like wget was the right tool.

A bit of research gave me

    wget -r -l1 --no-parent -A.JPG "site.com/images/"

You can change the JPG to jpg or GIF or gif or png etc to suit.

Tuesday, December 8, 2009

Installing Snow Leopard 10.6.2 on MSI Wind / Advent 4211

I bought a copy of Snow Leopard to have a go installing on the Wind. Currently Leopard 10.5.8 works great, other than the built-in mike doesn't work, but I can live with that.

Basically I followed these instructions.

1 - restore the install DVD to a USB stick

which you need to do because the USB is writeable and we need to modify some files on it

2 - Run NetBookBootMaker against the USB stick

BE VERY CAREFUL! Running on a real Mac against your HD will kill OSX!

Make sure you have 0.8.3RC4 since it fixes 10.6.2 to run on the Atom.

3 - Boot your Wind from the USB stick - press F11 on boot, or go into the BIOS and change the boot order.

4 - Install just like normal. Restart.

On the first run the trackpad didn't work properly - have a mouse ready

5 - Download the NetBookInstaller program and have ready to run, but don't run yet.

6 - Run the 10.6.2 combo updater. DO NOT RESTART!

7 - run the NetBookInstaller.
screenie here

8 - Restart, and you should be running 10.6.2!

Stuff thats not working:

Audio
Webcam
Bluetooth
Ethernet update: install the network kexts from 10.5.x
Quartz Extreme

Given that the only reason right now for doing this is to get find and sort by size back in the finder, I can't recommend it.

I'll keep looking for other methods.

Tuesday, December 1, 2009

Task Killer for Android

screenie from their site

Wondering why your Android is going slow? Takes 10 seconds to switch between screens and tasks? Battery going flat in now time? Maybe because the GPS is on?

Maybe you have too many things running, or something running you'd forgotten about, like the GSPS mapping / tracking App. Its not well known that switching between apps on the Android does not necessarily close them down, like it does on the iPhone.

Here's an App that shows you whats running and allows you to kill stuff you don;t need www.androidtapp.com/advanced-task-killer/