Sunday, February 14, 2010

OSX SnowLeopard: "The PPD is not compatible with Gutenprint 5.2.3"

I upgraded my MacBookPro to SnowLeopard, and one of the things not working was printing to my very venerable HP6L. I kept getting a "The PPD version (1137728) is not compatible with Gutenprint 5.2.3." message even though I was selecting GutenPrint 5.2.4.

I could print via a share to the same printer from another Mac running 10.5.8 Leopard, so I figured it was a GutenPrint issue.

Went to their page gimp-print.sourceforge.net/MacOSX.php (yes I know the link says gimp print) and on there they have an uninstaller to rid your machine of all version of GutenPrint. Then download and install the new GutenPrint 5.2.4 and I was good to go.

5 comments:

Anonymous said...

Excellent tip. I just installed OS X 10.6.3 and got the same PPD error message. Didn't have to run the uninstaller. The latest installer for 5.2.5 appeared to have done it (uninstall) automatically.

Kristy said...

Thank you!! installing the latest version of Guterprint solved my printer error easily.

Jackson said...

Made my day with this info - thanks very much.

mittelrl said...

Hey, thank you very much for the tip. My 990 Epson printer was giving me the same message and your suggested links worked perfectly. . .after installing, shutting off the printer and restarting the computer and turning on the printer back on.

Anonymous said...

Awesome. So simple. You just saved me.